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· The Dreamweaver workspace is the part of the window where you create, work 

with, and save Web pages

· The largest area in the workspace is the Document window. You use the 

Document window to create page content.

Get Started with Dreamweaver: Lesson 1, Exercise 1
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Application 

Bar

The Application bar is a menu bar that provides selections for creating and 

working with Web sites, pages, and objects. Objects are elements you add to 

a Web page. The various menusðFile, Edit, View, Insert, Modify, Format, 

Commands, Site, Window, and Helpðare grouped by the task you want to 

perform.

Get Started with Dreamweaver: Lesson 1, Exercise 1
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·The Document toolbar appears at the top of the Document window 

directly above the windowôs contents. The toolbar displays Code, Split, 

Design, and Live View buttons that you can use to toggle among the 

various views. You will learn more about these and other view options 

later in the course.

·The Document toolbar also shows the title of the current page and gives 

you easy access to tools that enable you to check browser compatibility, 

preview the page, and modify the display of page content.

Document

Toolbar
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· A panel group contains several related 
panels. The Files panel group contains the 
Files panel and the Assets panel. To switch 
from one panel to another in a group, 
simply click the panelôs tab.

· Panel groups can be opened and closed as 
you require. To open a panel group, double-
click the panelôs tab. To close a panel 
group, double-click the panel tab again.

· You can drag a panel group away from its 
default location by clicking panel tab and 
dragging the panel group to a new location. 
If you leave the panel group undocked in 
the workspace, you have created a floating 
panel group.

Get Started with Dreamweaver: Lesson 1, Exercise 1
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· When you set up a new Web site in 
Dreamweaver, you name the site and its 
folder, select your server, and specify 
where the site folder will be stored. 
Dreamweaver provides a wizard to walk 
you through the process. It is important 
to set up your site properly to ensure 
that all files used to create your Web site 
are stored together in the site folder. 
Otherwise, your site might not display 
properly.

· Before you begin, you will find it 
helpful to plan your Web site. Identify 
the number of pages you need and do a 
simple sketch to show how the pages 
are linked and what content they will 
provide. This sketch will serve as a map 
as you begin creating your site. 

· Your new siteðshown as a green 
folderðis listed in the Files panel in the 
panel group on the right side of the 
screen. The Files panel is where you 
work with all the files you need as you 
design your site.

Get Started with Dreamweaver: Lesson 1, Exercise 2
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· You can create new Web pages from the Start page if you have no other pages open in a site.

· The Start page also gives you the ability to open existing pages youôve created in Dreamweaver.

· When you have a page open in a site, you can create a new page using the File > New command.

Get Started with Dreamweaver: Lesson 1, Exercise 2
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ÅKnow your audience. Who will be visiting 
your site? Thinking through what they expect 
to seeð and then surpassing their 
expectationsðwill ensure a successful 
browsing experience for users.
ÅName your pages well. Search engines pick 
up the titles you useðthe title of your site as 
well as page titles. Make your titles clear and 
easy to understand.
ÅBe consistent. Consistency in color, graphics, 
and placement helps your visitor understand 
your site.
ÅMake your site easy to navigate. When 
visitors come to your Web site, they should be 
able to tell from your home page how to get 
around your site and find the features they 
need.
ÅPay attention to connection speed. If it takes 
too long to download your Web site, your 
visitors will not return. Time is valuable, both 
theirs and yours.

ÅKeep it simple. Clean lines and clear, easy-to-
read content are features you always should 
keep in mind when building your site.
ÅBe unique. When you copy another 
designerôs site ideas, you are not only 
plagiarizing but also limiting your own ideas 
and site potential.
ÅTake it easy. Resist the temptation to overdo 
your site by loading it up with large image 
files or media objects. The more you add, the 
more you may affect your site download times. 
And visitors love fast-loading sites.
ÅRespect your visitors. Make sure your site 
looks professional from the very first moment 
it is online. Donôt fall into the habit of posting 
a ñconstruction guyò graphic or similar icon to 
notify your visitors that your site is under 
construction. If your visitors are visiting your 
site for information, when they donôt find what 
they are looking for, they likely will look 
elsewhere.

Get Started with Dreamweaver: Lesson 1, Exercise 29
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Get Started with Dreamweaver: Lesson 1, Exercise 3

· HTML (Hypertext Markup Language) is a scripting languageðor codeðyou 
use to create pages that can be viewed with a Web browser. Nearly every item 
on a Web pageðIncluding text, formatting, pictures, and other page 
elementsðis controlled by HTML coding.

· Dreamweaver CS4 supports XHTML (Extensible Hypertext Markup 
Language). XHTML is a reformulation of the most current version of HTML 
(HTML 4.0) that uses XML (Extensible Markup Language). XML is a 
language that uses tags to structure information, similar to HTML. Unlike 
HTML, however, XML allows you to create your own tags to fit your 
information more specifically. XHTML was developed to answer a need for a 
stricter version of HTML that could be used to deliver content across a wide 
variety of devices: not merely computer browsers, but also mobile phones, 
laptops, PDAs, and so on. XHTML combines the standard HTML structure 
with the power and flexibility of XML.
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Get Started with Dreamweaver: Lesson 1, Exercise 3

· To make sure others can find and visit your site, you can supply keywords on your pages 
that search engines use to index a site in their databases.

· You add keywords to the Head section of a site using a <meta> tag.

· To add a <meta> tag containing keywords to your home page, use the Insert > HTML > 
Head Tags > Keywords menu command to open the Keywords dialog box. Here you can 
type the keywords that summarize your siteôs subject.
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Get Started with Dreamweaver: Lesson 1, Exercise 3

·You can display rulers on the pages so you can easily position 
content on the page. You add rulers to the work area by opening the 
View menu, clicking Rulers, and choosing Show. 

·A newly opened Dreamweaver document displays a blinking 
insertion point at the top left of the Document window. To enter text 
on a page, simply begin typing at the location of the insertion point.
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Working with Text Using CSS Styles and HTML: Lesson 2, 

Exercise 8

The easiest way to insert Office text in a Dreamweaver page is to use the 
File > Import > Word Document or File > Import > Excel Document menu 
command. This command displays the Import Word Document or Import 
Excel Document dialog box, where you can navigate to the location of the 
Word or Excel document you want to insert.

Å Another method of inserting Office information 
into a Dreamweaver page is to drag the file itself 
from an application such as Windows Explorer 
or the Dreamweaver Files panel onto the 
Dreamweaver page.

Å After you drag file icon to the page and release 
the mouse button, Dreamweaver displays the 
Insert Document dialog box.
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Working with Text Using CSS Styles and HTML: Lesson 2, Exercise 8

You can also insert Office document text 

using the Copy and Paste commands. 

Copy the Word text or Excel spreadsheet 

data and then use one of the

following Paste options:

ÅUse Edit > Paste to convert the pasted 

text to HTML format, the same as when 

importing a Word or Excel file.

ÅUse Edit > Paste Special to open the 

Paste Special dialog box.
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Working with Text Using CSS Styles and HTML: Lesson 2, Exercise 8

Å Text you type in a Dreamweaver document is formatted with a default appearance, 
Including the typeface, size, and color (black). A typeface is a set of alphabetic 
characters, numbers, and punctuation marks in a specific design. Dreamweaver also 
applies a default style (Paragraph).You can change text typeface, size, style, and color 
using tools in the CSS page of the Property inspector.

Å By default, the Dreamweaver font list offers only a few popular fonts that display 
well in most browsers. You can, however, add fonts to the list using the Edit Font List 
option at the bottom of the Property inspectorôs font list (or click Format > Font > 
Edit Font List).

Å You can choose a different font size for selected text by highlighting it and clicking 
the Size arrow in the CSS page of the Property inspector to display the list of 
available font sizes.
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Working with Text Using CSS Styles and HTML: Lesson 2, Exercise 9

Å A style is a rule that contains 
instructions on how to format an HTML 
element. A style may be applied to text (like 
styles in a word processing program such as 
Word) or to other HTML elements such as 
images, AP divs, or frames. You can also 
create styles that apply to specific HTML 
tags such as the horizontal rule tag or a 
heading tag.

Å A collection of styles created for a page or a 
Web site is called a style sheet. Using a 
style sheet, you can format a number of 
HTML elements quickly and easily. 
Dreamweaver supports Cascading Style 
Sheets (CSS), style sheets developed 
specifically for use in Web design.

Å Creating a new style involves choosing the 
CSS selector type(class, ID, tag, or 
compound); namingthe style, and choosing 
where the rule will be used.
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Working with Text Using CSS Styles and HTML: Lesson 2, Exercise 9
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Working with Text Using CSS Styles and HTML: Lesson 2, Exercise 10

Å If you want to apply styles to several Web 
pages in a site, you need to create an 
external style sheet. An external style sheet 
is a separate, or external, file that provides 
the definitions of all the styles used in a 
Web site.

Å External style sheets have the file extension 
.css.

Å After you have created an external style 
sheet, you can attach it to existing or new 
documents in the site. This allows you to 
use the same styles on all pages to ensure 
consistency throughout your site.

Å For most cases, choose the Link option in 
the Attach External Style Sheet dialog box. 
If you select the Import option, the styles 
are directly imported into the document 
rather than linked to the external file.
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Working with Text Using CSS Styles and HTML: Lesson 2, Exercise 11

You can change the alignment to center text or right-align text using the Align Center or 
Align Right button on the CSS page of the Property inspector. Return text to left 
alignment using the Align Left button.

Web pages often Include lists to emphasize text items and enable readers to find 
information quickly and easily. You can create two types of lists using buttons on the 
HTML page of the Property inspector: unordered lists and ordered lists.

You can indent or outdent text from the left and right margins using the Text

Indent or Text Outdent button on the Property inspector.
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Working with Text Using CSS Styles and HTML: Lesson 2, Exercise 11

You can insert the current date on any page 
in your site using Dreamweaverôs Date 
feature. If you choose, the inserted date 
updates each time you save the page. This is 
a good way to keep track of modifications 
made to a Web site.

Display the History panel using the 
Window > History command.

Not only can you keep track of the tasks 
you have performed in the History panel, 
but you also can use the History panel to 
repeat a series of steps or undo a number 
of recent tasks quickly and easily.
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